Migrate legacy application using Oracle 10g to Oracle 12c

By | February 18, 2019

After upgrading my developement Oracle database to 12c I discovered that an old legacy application still under support was no longer working throwing the following Oracle error:

ORA-28040: No matching authentication protocol

After some digging I found the following reported bug:

Bug 14575666

In 12.1, the default value for the SQLNET.ALLOWED_LOGON_VERSION parameter has been updated to 11. This means that database clients using pre-11g JDBC thin drivers cannot authenticate to 12.1 database servers unless theSQLNET.ALLOWED_LOGON_VERSION parameter is set to the old default of 8.

Contribute to this site maintanance !

This is a self hosted site, on own hardware and Internet connection. The old, down to earth way 🙂. If you think that you found something useful here please contribute. Choose the form below (default 1 EUR) or donate using Bitcoin (default 0.0001 BTC) using the QR code. Thank you !

€1.00

Advertisements

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.